This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Piping on 64-bit Cygwin was Re: [ANNOUNCEMENT] llvm 3.7.1-2

On Jun 20, 2016, at 10:53 PM, wrote:
> Yes, it's the same piping problem of three years ago.

âwhere you were asked to provide a simple test case for the problem, instead of âcompile admittedly difficult-to-build package Geomview and use it against one of the most complicated packages in Cygwin, OpenGL.â

Hereâs what a simple test case looks like:

  $ dd if=/dev/urandom bs=4k count=4m | 
    gpg -c --force-mdc | 
    gpg -d > /dev/null

Type the same passphrase three times: twice to verify it for encryption, and once for decryption.  The fact that this runs without errors proves that Cygwin 64 is capable of reliably transporting 16 GiB of data through a pipe without corruption.  

Try it on your system.  If it gives an error, it shows that the problem is system-specific, and thus possibly BLODA or some other platform issue.

If not, then please explain how your problem differs from the demonstration here.

Have you ruled out Cygwinâs OpenGL package, such as by running it over X11 to a remote system running a different implementation?
Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]