This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Piping on 64-bit Cygwin was Re: [ANNOUNCEMENT] llvm 3.7.1-2


this piping problem on 64-bit Cygwin between Geomview and its modules (of which SaVi is the most used example) is entirely unrelated to OpenGL, and exists when Geomview is compiled without OpenGL.

Three years ago, 64-bit OpenGL not yet working at all was simply motivation to see how the then-new 64-bit Geomview fleshed out. Intermittent problems with 32-bit OpenGL crashing are more motivation to get this piping issue fixed, as is the fact that 64-bit anything is the future. I hope that's clear.

I don't have the technical knowledge to reduce Geomview's internal complexities to a simple C program doing piping to reproduce this piping problem, which is what is being asked for. Geomview IS the test case. Your piping-works-in-general example is unrelated to this.

I've reproduced this SaVi-can't-talk-with-Geomview-on-64-bit-cygwin problem on multiple installs on multiple machines over the past three years, both Windows 10 and Windows 7, and have it on two Windows 10 machines and a Windows 7 machine right now. Yes, that is six Cygwin installs, each machine both 32 and 64-bit.

Yes, Geomview is complex to install, which is why I maintain

updating those instructions every so often requires destroying and recreating Cygwin installs from scratch to see what the current required packages are, or have been renamed to, through trial and error, taking most of a workday. Which is why I have multiple installs on multiple machines. Having Geomview as a Cygwin package would be great by comparison.

Lloyd Wood

(you might want to turn off non-ascii apostrophes. They don't seem to match your encoding, as shown in the web mailarchive.)

Warren Young writes:

On Jun 20, 2016, at 10:53 PM, wrote: 
> Yes, it's the same piping problem of three years ago. 

where you were asked to provide a simple test case for the problem, instead of compile admittedly difficult-to-build package Geomview and use it against one of the most complicated packages in Cygwin, OpenGL. 

Here's what a simple test case looks like: 

$ dd if=/dev/urandom bs=4k count=4m | 
gpg -c --force-mdc | 
gpg -d > /dev/null 

Type the same passphrase three times: twice to verify it for encryption, and once for decryption.  The fact that this runs without errors proves that Cygwin 64 is capable of reliably transporting 16 GiB of data through a pipe without corruption. 

Try it on your system.  If it gives an error, it shows that the problem is system-specific, and thus possibly BLODA or some other platform issue. 

If not, then please explain how your problem differs from the demonstration here. 

Have you ruled out Cygwin's OpenGL package, such as by running it over X11 to a remote system running a different implementation?

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]