This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: wget 1.17.x creates odd permissions on downloaded files

Greetings, Zube!

> wget 1.16.3 seemed to work fine for a simple task, that is to download
> putty.exe from a local http site.  Start up a normal windows cmd.exe,
> download, run, no muss, no fuss.

> The last two wget versions (1.17.1-1 and -2) seem to exhibit the
> following issues when putty.exe is downloaded.

> 1) putty will not execute.  Error is "Access is denied".

That depends on the permission model you're using for directory, where you are
downloading the file to.
If you are using Cygwin ACL's, then the behavior is POSIX, and the new file
will not receive +x by default.

> 2) Examining the permissions on putty.exe, the first thing that
> comes up is an error that reads:

> "The permissions on putty.exe are incorrectly ordered, which may
> cause some entries to be ineffective."

> The permissions are odd.  When compared to a working machine (wget
> 1.16.3, cygwin 2.3.1) there is an additional group ("NULL SID") with
> special access of type Deny and several of the other users and groups
> have similar "type Deny" restrictions.

This is how Cygwin works around certain incompatibilities between Windows and
POSIX permission models.
Do NOT fall into a trap and believe that Explorer trying to drag you to.
The permissions are correct, it's just that Explorer is unable to deal with
them, because all it knows is so-called "canonical" order.

> If I use a browser to download the file or a different version of wget
> (e.g. and drop putty.exe in
> the same directory, there are no issues.  It also doesn't matter where
> the file is dropped.  

> This occurs on both a Windows 7 64-bit machine that has had
> 32-bit cygwin upgraded multiple times and on a new Windows 10
> 64-bit machine with 32-bit cygwin installed fresh.  It occurs
> under cmd.exe and also under Cygwin.bat, for both administrators
> and non-administrators.

> Any help greatly appreciated.  Thank you for your time.

If you want Windows behavior, use noacl flag on non-Cygwin mounts.


# RAM disk
W:/ /var/run ntfs acl,binary,nouser,posix=0 0 0
# /cygdrive mount
none /cygdrive cygdrive noacl,binary,nouser,posix=0 0 0
# Map user homes to /home
C:/Users /home bind noacl,binary,exec,posix=0 0 0
# And /tmp to user %TEMP%
none /tmp usertemp binary,user,notexec,posix=0 0 0

With best regards,
Andrey Repin
Thursday, June 23, 2016 13:21:51

Sorry for my terrible english...

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]