This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Setup of texlive-collection-basic waits in postinstall/0p_texlive_prep.dash

On 30/06/2016 12:34, Marco Atzeri wrote:
On 30/06/2016 11:11, Pavel Kudrna wrote:
I have problem installing texlive-collection-basic on 32bit XP. It is
not fresh install.

If I select texlive only the Cygwin Setup finishes successfully,
/var/log/setup.log shows

2016/06/30 09:31:01 NOTE!  User refused suggested missing
dependencies!  Expect some packages to give errors or not function at

This eventually is a potential problem

I tried that to narrow down the problem so in this case I refused the dependency which was on texlive-collection-basic only.

2016/06/30 09:31:03 Extracting from

2016/06/30 09:31:05 Changing gid back to original
2016/06/30 09:31:05 running: C:\PROGRA~1\cygwin\bin\dash.exe
2016/06/30 09:31:15 running: C:\PROGRA~1\cygwin\bin\dash.exe
2016/06/30 09:31:16 running: C:\PROGRA~1\cygwin\bin\dash.exe
2016/06/30 09:31:17 running: C:\PROGRA~1\cygwin\bin\dash.exe
2016/06/30 09:31:17 Changing gid to Administrators
2016/06/30 09:31:19 note: Installation Complete
2016/06/30 09:31:19 Ending cygwin install

Newertheless in /etc/postinstall files I see files


without .done suffix. Is it already symptom of problem?

No. These special ones are run every time setup runs to handle
key updates.


The main problem is installing texlive-collection-basic. Setup waits at
/etc/postinstall/0p_texlive_prep.dash while
in /var/log the file setup.log.runXa03548 grows by repeating lines

      2 [main] perl 3928 child_info_fork::abort: unable to remap
Util.dll to same address as parent (0x6F0000) - try running rebaseall
Can't fork, trying again in 5 seconds at
/usr/share/tlpkg/TeXLive/ line 228.
      1 [main] perl 2520 child_info_fork::abort: unable to remap Cwd.dll
to same address as parent (0x6C0000) - try running rebaseall
Can't fork, trying again in 5 seconds at
/usr/share/tlpkg/TeXLive/ line 228.

How many packages have you installed ?
0x6C0000 is a very low address

At this step texlive-collection-basic only, there was no dependency on other packages indicated.

But before it was update of many packages suggested by Setup which was not successfull.

Have you any comment on perl and dash processes after manual stop of Setup?

Thank you for help.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]