This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [ANNOUNCEMENT] Updated: xorg-server-1.18.3-1

On 21/06/2016 19:04, Jon Turney wrote:

The following packages have been updated in the Cygwin distribution:

*** xorg-server-*1.18.3-1

These packages contain XWin and the other X.Org X11 servers.

In addition to upstream fixes [1], the following cygwin-specific changes
have been made since 1.18.2-1:

* In multiwindow mode, enable the -compositewm option by default, so
top-level window contents which are occluded are shown correctly in task
bar and task switcher previews.  Add a -nocompositewm option so it can
be disabled.
* Fix any custom sysmenu configured in .XWinrc not being used when
window is initially shown (Thanks to Colin Harrison)


32 bit seem to have an issue. 64 bit is fine

$ startxwin
xauth: (stdin):2:  unknown command "086295becc62502e7c43cb93e1b5b8d1"

Welcome to the XWin X Server
Vendor: The Cygwin/X Project
OS: CYGWIN_NT-6.1-WOW GE-MATZERI-EU 2.5.2(0.297/5/3) 2016-06-23 14:27 i686
OS: Windows 7 Service Pack 1 [Windows NT 6.1 build 7601] (WoW64)
Package: version 1.18.3-1 built 2016-06-20

XWin was started with the following command line:

/usr/bin/XWin :0 -multiwindow -auth /home/marco/.serverauth.7560

(II) xorg.conf is not supported
(II) See for more information
LoadPreferences: /home/marco/.XWinrc not found
LoadPreferences: Loading /etc/X11/system.XWinrc
LoadPreferences: Done parsing the configuration file...
winDetectSupportedEngines - RemoteSession: no
winDetectSupportedEngines - DirectDraw4 installed, allowing ShadowDDNL
winDetectSupportedEngines - Returning, supported engines 00000005
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

Previous version also fails, just later

winProcEstablishConnection - winInitClipboard returned.
winClipboardThreadProc - DISPLAY=:0.0
OS maintains clipboard viewer chain: yes
OS maintains clipboard viewer chain: yes
winMultiWindowXMsgProc - xcb_connect() returned and successfully opened the disp lay. winClipboardProc - XOpenDisplay () returned and successfully opened the display.
xinit: connection to X server lost

waiting for X server to shut down winClipboardProc - winClipboardFlushWindowsMes sageQueue trapped WM_QUIT message, exiting main loop.
winClipboardProc - XDestroyWindow succeeded.
winMultiWindowXMsgProc - Fatal error 1 on xcb connection
winDeinitMultiWindowWM - Noting shutdown in progress
(II) Server terminated successfully (0). Closing log file.

Unfortunately I am mainly using the 64bit, so I don't know
when the problem arose.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]