This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [ANNOUNCEMENT] Updated: xorg-server-1.18.3-1

On 11/07/2016 23:13, Jack wrote:
On 2016.07.11 16:31, Marco Atzeri wrote:

On 21/06/2016 19:04, Jon Turney wrote:

The following packages have been updated in the Cygwin distribution:

*** xorg-server-*1.18.3-1

These packages contain XWin and the other X.Org X11 servers.

In addition to upstream fixes [1], the following cygwin-specific changes
have been made since 1.18.2-1:

* In multiwindow mode, enable the -compositewm option by default, so
top-level window contents which are occluded are shown correctly in task
bar and task switcher previews.  Add a -nocompositewm option so it can
be disabled.
* Fix any custom sysmenu configured in .XWinrc not being used when
window is initially shown (Thanks to Colin Harrison)


32 bit seem to have an issue. 64 bit is fine


It works fine for me, with cygwin 32 bit under Windows 7 Pro 32 bit,
although my CPU is actually 64 bit.  Let me know if you want any other
details about my system.


Thanks for the confirmation.

After a reboot the 32 bit restarted to work, I suspect there was
some type of race and XWin was always loosing.

I am back to the *normal* with both versions, where normal means
only the first race is usually lost but all the successive are fine.

May be WOW need more time to load dll's.

$ uname -svrm
CYGWIN_NT-6.1-WOW 2.5.2(0.297/5/3) 2016-06-23 14:27 i686

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]