This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

httpd-2.4.23 notice "No slotmem from mod_heartmonitor"

After obtaining the upgrade of the httpd package from 2.4.22 to 2.4.23, I received the following error on attempted startup:

    [Mon Jul 25 08:22:26.529504 2016] [proxy_balancer:emerg] [pid 1234] AH01177: Failed to lookup provider 'shm' for 'slotmem': is 
    mod_slotmem_shm loaded??

Activating mod_slotmem_shm (as a shared module) resolved this issue and allowed httpd to start.  However, httpd now produces the following notice on (successful) startup:

    [Mon Jul 25 09:27:40.718810 2016] [lbmethod_heartbeat:notice] [pid 2345] AH02282: No slotmem from mod_heartmonitor

I'm wondering if there changes to the static modules included in the new version's package.  The changelog for httpd itself didn't suggest any changes between these two versions that would cause configuration differences.

I have tried activating mod_heartmonitor and mod_heartbeat from my configuration file, but the notice still appeared.  I also tried activating mod_slotmem_plain with the same result.


Dominic R. Jones, Ph.D.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]