This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: Postinstall script errors on cygwin x86 install


Tatsuro MATSUOKA started this thread
back on Mon, 11 Apr 2016 05:18:30 +0900 (JST), which I stumbled across just now from a web search.

I recently encountered a very similar problem, and I think that I have a simple solution, so I wanted to followup.


First some background:

--I was forced at work to downgrade from Win 7 to Win 10 spyware as a service a few weeks ago

--at the time of that downgrade, I had some problems with cygwin, so I did a clean install of 32 bit cygwin

--I vaguely recall a few post installation warnings at that time, but I did not note them; furthermore, cygwin seemed to subsequently work

--this morning, however, some R code failed that worked just 2 days ago (and was not changed in the interim...)
    --actually, it was the R C++ compiler of some critical methods that was failing, not R per se
    --the warning message was:
        Warning: running command 'C:/PROGRA~1/RRO/R-31~1.2/bin/x64/R CMD SHLIB file9d81bb03ccf.cpp 2> file9d81bb03ccf.cpp.err.txt' had status 1
              0 [main] make (1584) c:\Rtools\bin\make.exe: *** fatal error - cygheap base mismatch detected - 0xFCF408/0xDDF408.
        This problem is probably due to using incompatible versions of the cygwin DLL.
        Search for cygwin1.dll using the Windows Start->Find/Search facility
        and delete all but the most recent version.  The most recent version *should*
        reside in x:\cygwin\bin, where 'x' is the drive on which you have
        installed the cygwin distribution.  Rebooting is also suggested if you
        are unable to find another cygwin DLL.
              0 [main] make 2544 fork: child -1 - forked process 1584 died unexpectedly, retry 0, exit code 0xC0000142, errno 11


After that error, I tried another clean reinstall of 32 bit cygwin.  My steps were simply:
    1) I deleted these entire directory trees:
        <path to setup-x86.exe>\
    2) I reran setup-x86.exe

At the end of this reinstall, setup-x86.exe popped up a dialog that listed these post install errors:
    Package: 0/Perpetual
        0p_000_autorebase.dash exit code 2
        0p_update-info-dir.dash exit code 2
    Package: _/base-cygwin exit code 254
    Package: _/coreutils exit code 254
    Package: _/bash exit code 254
    Package: _/base-files exit code 254 exit code 254
    Package: _/ca-certificates exit code 254
    Package: _/lynx exit code 254
    Package: _/man-db exit code 254
    Package: _/mintty exit code 254

That list is very similar to Tatsuro's.


To make a long story short, the cure for my post install errors was to do another clean install that included CLEANING THE REGISTRY AS WELL.

In particular, these are the exact reinstall steps that worked for me:
    1) delete these entire directory trees:
        <path to setup-x86.exe>\
    2) run regedit and ENTIRELY delete BOTH of these registry trees:
    3) restart your computer
    4) rerun setup-x86.exe

The above is an abbreviated version of the steps described in
(I did not need to do the other steps, since my installation had nothing fancy like cygwin services running.)

When I did the above, setup-x86.exe ran to completion with no errors whatsoever.  Furthermore my cygwin install seems to work fine (as does the R code failed this morning).

Hope this helps someone else in the future.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]