This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Attempting to build cygwin1.dll

System details first: "CYGWIN_NT-5.1 GKDC531 2.5.2(0.297/5/3) 2016-06-23 14:27 i686" on Windows XP SP3, on a dual-core Pentium 4 (i786) box.

I have rebuilt and optimized gcc and several math libraries with the architecture-specific options of gcc, `-march=native' and `-mfpmath=sse', to get the most out of my old box. This strategy has proven successful; my gcc build runs noticeably faster than the distribution version. Ultimately, I hope to build an ffmpeg that also runs a bit faster. (As things are, ffmpeg can take *days* to recode a feature-length video on my box.)

Following the instructions in section 6.21 of the FAQ, I installed the various build tools (cocom, etc.) and then...

$ (/home/projects/newlib-cygwin/configure --prefix=/usr -v CFLAGS='-O3 -march=native -mfpmath=sse' CXXFLAGS='-O3 -march=native -mfpmath=sse'; make) |& tee build.log
configure: loading site script /usr/share/
checking build system type... i686-pc-cygwin
checking host system type... i686-pc-cygwin
checking target system type... i686-pc-cygwin
checking for a BSD-compatible install... /bin/install -c
checking whether ln works... yes
checking for isl 0.16, 0.15, or deprecated 0.14... yes   \ ?
checking for isl 0.16 or 0.15... no                      / ?
[Everything going well, until...]
checking for i686-w64-mingw32-gcc... i686-w64-mingw32-gcc
checking for x86_64-w64-mingw32-gcc... no
configure: error: no acceptable mingw64 cc found in $PATH
configure: error: /home/projects/newlib-cygwin/winsup/lsaauth/configure failed for lsaauth
make[1]: *** [Makefile:9420: configure-target-winsup] Error 1
make[1]: Leaving directory '/home/projects/cygwin_build'
make: *** [Makefile:883: all] Error 2

I am sure I have all the support libraries for the 32-bit mingw gcc installed and working (I've built software with it). Does this mean a 64-bit machine is required to build the Cygwin DLL?

I tried the Newlib-Cygwin distribution sources, and I downloaded the sources from git://, all with the same result.

A Google search turned up only one article that might be helpful:

"After a great struggle (and lots of googling around) i finally compiled cygwin1.dll on linux and tested in a win32 environment, the process wasn't straightforward but it worked."

Some of this I could follow, but some of it was well beyond me.

Really, all I need from the Newlib-Cygwin package are libm and the Cygwin dll, optimized by being built architecturally specific so that I can build ffmpeg (and maybe some other things, similarly optimized) on this platform, and hope they do not take days to complete a job.

Please help?


By the way, how is cocom to be used to build Newlib and the DLL? What little documentation that comes with the Cygwin package is.... intriguing...

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]