This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Windows 7 update broke Cygwin X?


After a recent Windows update, I am unable to start Cygwin's X server
anymore. I tried updating to the latest Cygwin by running setup again,
/usr/bin/rebaseall and rebooting. There are no obvious errors from the
X server if I run /usr/bin/startxwin from a Cygwin console, but it
seems to exit after 20 seconds or so:

$ date; /usr/bin/startxwin; date
Fri, Sep 09, 2016 12:00:58 PM

Welcome to the XWin X Server
Vendor: The Cygwin/X Project
OS: CYGWIN_NT-6.1-WOW 3QGH462 2.6.0(0.304/5/3) 2016-08-31 14:27 i686
OS: Windows 7 Service Pack 1 [Windows NT 6.1 build 7601] (WoW64)
Package: version 1.18.4-1 built 2016-07-22

XWin was started with the following command line:

/usr/bin/XWin :0 -multiwindow -auth /home/jhoke/.serverauth.5404

(II) xorg.conf is not supported
(II) See for more information
LoadPreferences: /home/jhoke/.XWinrc not found
LoadPreferences: Loading /etc/X11/system.XWinrc
LoadPreferences: Done parsing the configuration file...
winDetectSupportedEngines - RemoteSession: no
winDetectSupportedEngines - DirectDraw4 installed, allowing ShadowDDNL
winDetectSupportedEngines - Returning, supported engines 00000005
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
Fri, Sep 09, 2016 12:01:19 PM

Any ideas about what how to fix or troubleshoot this? I use it all the
time and it worked before this update.

Joshua Hoke

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]