This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

location of native rxvt binaries?


I have been a cygwin user for at least 16 years now and first off want to say thanks
for the hard work!

I have a new Windows 2008 R2 server I would like some basic cygwin tools on, one of the
most important is the native rxvt.

But it seems both the 32-bit and the 64-bit versions of rxvt included with cygwin as downloaded today are not native, but require X instead. Another telltale sign is there was no windows icon within the rxvt.exe binary in the versions I downloaded

I tried copying an older rxvt binary but it did not work.

here is what the current /cygdrive/c/cygwin/bin/rxvt.exe is linked to:

        ntdll.dll => /cygdrive/c/Windows/SYSTEM32/ntdll.dll (0x77400000)
kernel32.dll => /cygdrive/c/Windows/system32/kernel32.dll (0x772e0000) KERNELBASE.dll => /cygdrive/c/Windows/system32/KERNELBASE.dll (0x7fefd1f0000)
        cygwin1.dll => /usr/bin/cygwin1.dll (0x180040000)
        cygX11-6.dll => /usr/bin/cygX11-6.dll (0x3ffed0000)
        cygxcb-1.dll => /usr/bin/cygxcb-1.dll (0x3ff3f0000)
        cygXau-6.dll => /usr/bin/cygXau-6.dll (0x3ffec0000)
        cygXdmcp-6.dll => /usr/bin/cygXdmcp-6.dll (0x3ffeb0000)
        cygXpm-4.dll => /usr/bin/cygXpm-4.dll (0x3ffe90000)

vs the native rxvt on my laptop (not sure how old the installation is 1 or 2 years).

        ntdll.dll => /cygdrive/c/Windows/SysWOW64/ntdll.dll (0x777c0000)
kernel32.dll => /cygdrive/c/Windows/syswow64/kernel32.dll (0x75170000) KERNELBASE.dll => /cygdrive/c/Windows/syswow64/KERNELBASE.dll (0x765c0000)
        cygwin1.dll => /usr/bin/cygwin1.dll (0x61000000)
USER32.dll => /cygdrive/c/Windows/syswow64/USER32.dll (0x754f0000)
        GDI32.dll => /cygdrive/c/Windows/syswow64/GDI32.dll (0x76e60000)
        LPK.dll => /cygdrive/c/Windows/syswow64/LPK.dll (0x77020000)
        USP10.dll => /cygdrive/c/Windows/syswow64/USP10.dll (0x76510000)
msvcrt.dll => /cygdrive/c/Windows/syswow64/msvcrt.dll (0x76a70000) ADVAPI32.dll => /cygdrive/c/Windows/syswow64/ADVAPI32.dll (0x77050000) sechost.dll => /cygdrive/c/Windows/SysWOW64/sechost.dll (0x76ef0000) RPCRT4.dll => /cygdrive/c/Windows/syswow64/RPCRT4.dll (0x76cf0000) SspiCli.dll => /cygdrive/c/Windows/syswow64/SspiCli.dll (0x75110000) CRYPTBASE.dll => /cygdrive/c/Windows/syswow64/CRYPTBASE.dll (0x75100000)
        IMM32.DLL => /cygdrive/c/Windows/system32/IMM32.DLL (0x76e00000)
        MSCTF.dll => /cygdrive/c/Windows/syswow64/MSCTF.dll (0x77120000)

I do recall at one point 64-bit cygwin did not have a native rxvt, I came across
this url which seems to indicate that may not be the case anymore:

But in any case I tried installing 32-bit first, since that is what I am used to using, and the results were the same. I ran "file" against the 32-bit version
to verify it was a 32-bit binary.

I have older cygwin archives but they seem to not be compatible with 2008 R2, get
lots of post install errors and the cygwin bash does not fire up.

Also tried copying the binary from my laptop as well as another windows 2008 (non R2)
server, but the binaries did not execute on 2008 R2, ldd says

        ntdll.dll => /cygdrive/c/Windows/SYSTEM32/ntdll.dll (0x77400000)
        ??? => ??? (0x775e0000)
        wow64.dll => /cygdrive/c/Windows/SYSTEM32/wow64.dll (0x72db0000)
wow64win.dll => /cygdrive/c/Windows/SYSTEM32/wow64win.dll (0x72d50000) wow64cpu.dll => /cygdrive/c/Windows/SYSTEM32/wow64cpu.dll (0x748d0000)

I have done several web searches but all of the results so far seem to mirror my past experience, native binary should be there but for some reason it is not.

thanks for any tips..


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]