This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: cpan broken ???

On Mon, Feb 5, 2018 at 3:45 PM, Jostein Berntsen wrote:
> On 05.02.18,16:59, Pavel Fedin wrote:
>>  I am trying to install a Perl module via CPAN and it fails:
>> --- cut ---
>> Warning: prerequisite Test::Warn 0 not found.
>> Could not load PERL_YAML_BACKEND 'YAML'
>>  at /usr/share/perl5/5.26/CPAN/ line 622.
>> Warning: No success on command[/usr/bin/perl Makefile.PL]
>>   YANICK/Parallel-ForkManager-1.19.tar.gz
>>   /usr/bin/perl Makefile.PL -- NOT OK
>> --- cut ---
>>  I've just updated; the system is x86-64. How to fix this?
> You can try "sudo cpan install YAML" first on the command line. Also
> check that you have 'make' installed.

It says
/usr/bin/perl Makefile.PL -- NOT OK

I believe 'make' was not run at all. Maybe something (either the
package or CPAN itself) needs YAML.

GCS a+ e++ d- C++ ULS$ L+$ !E- W++ P+++$ w++$ tv+ b++ DI D++ 5++
The Tao of math: The numbers you can count are not the real numbers.
Life is complex, with real and imaginary parts.
"Ok, it boots. Which means it must be bug-free and perfect. " -- Linus Torvalds
"People disagree with me. I just ignore them." -- Linus Torvalds

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]