This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: "ls" doesn't show postscript files any longer

On Mon, 19 Feb 2018 12:24:24, Siegmar Gross wrote:
> Hi,
> I'm using Cygwin on top of Windows 7 (all updates installed).
> "ls" doesn't show postscript files any longer after upgrading
> all installed Cygwin packages to the latest versions. I create
> the postscript file with MS Word 2003 using the "HP Color LJ
> 4550 PS" driver and printing to a file. In the past these files
> were visible.
> hermes temp 10 uname -a
> CYGWIN_NT-6.1 hermes 2.10.0(0.325/5/3) 2018-02-02 15:16 x86_64 Cygwin
> hermes temp 11 ls
> MpCmdRun.log
> hermes temp 12 ls *.ps
> ls: No match.
> hermes temp 13 ls
> hermes temp 14 file
> PJL encapsulated PostScript document text
> hermes temp 15
> Does anybody know why I don't see the existing file any longer?


Please, do as suggested by Marco Atzeri.

 - stop everything "Cygwin" related, and
 - replace the cygwin1.dll by the one you will find here

Download and
extract the cygwin1.dll.

As verification of what Marco believes to be the culprit, I "printed" to a file
from Word 2007.

This file proved to be "invisible" for ls (but not to the cmd's dir command).

The Windows Explorer shows that the file has the T attribute ... You may use
properties > details to verify if the same is true for

After replacing the cygwin1.dll with the latest version, the file "reappeared"
again to ls.

Please, report back here (using BOTTOM-posting - as I do here).


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]